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Introduction to the Freeway Facility Module 

This module performs level of service analysis for a freeway facility.  A freeway facility is an extended 
length of freeway composed of continuously connected basic freeway, weaving, merge, and diverge 
segments.  The underlying analysis methodologies are based on Chapters 10 and 25 of the HCM. 
 
The freeway facility module, as well as all other modules of HCM-CALC, was developed by Scott S. 
Washburn, Ph.D. P.E. Dr. Washburn also developed the FREEPLAN software program, which 
implements the Freeway Facilities analysis procedure at a planning and preliminary engineering level. 
FREEPLAN was developed specially for the Florida Department of Transportation. 

Getting Started 

After you have installed HCM-CALC, double-click on the program icon on your desktop or within the 
‘Start’ menu.  Alternatively, you can navigate to the installation folder and double-click on 
‘HCMCalc.exe’ to start the program. 
 
From the start screen (Figure 1), select ‘Freeway Facility’ and then click ‘Load Analysis Module’.  
Alternatively, you can double-click with the left mouse button on ‘Freeway Facility’ and the module will 
load automatically. 
 

 
Figure 1 
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Main Screen 

 
 

File Menu and Upper Toolbar 

Start a New Project File 

When you start the Freeway Facility module, it will automatically create a new project file, named 
“untitled.xff”.  You can create a new project file at any time by selecting ‘New’ under the ‘File’ menu 

or click on the  button on the toolbar. 

Open a Project File 

Select the 'File' menu and click on 'Open', or click on the  button on the toolbar.  If an existing 
project file is open for which changes have not been saved, the program will ask whether you want to 
save the existing project file before creating a new one. 
 
After at least one project file has been previously opened, the dialog shown in Figure 2 will load, 
showing a list of previously opened files.  Otherwise, the standard Windows file open dialog will appear. 
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Figure 2 

 
The name of the currently opened project is shown in the upper right portion of the main screen. 

Save a Project File 

There are two different types of save commands. One is ‘Save’ and the other is ‘Save As’.  ‘Save As’ is 
used to save a previously unsaved project or to rename an existing one, while ‘Save’ is for updating the 
file contents of a currently named project. 
 
To ‘Save As’, go to the ‘File’ menu and select ‘Save As’.  To ‘Save’, either go to the ‘File’ menu and select 

‘Save’, or click on the button on the toolbar.  If you select ‘Save’ from the file menu or the toolbar 
button, and you have not previously saved the file, the program will bring up the ‘Save As’ dialog box. 
 
Keep in mind that file names cannot include any of the following characters:  

 forward slash (/) 

 backslash (\) 

 greater than sign (>) 

 less than sign (<) 

 asterisk (*) 

 period (.) 

 question mark (?) 

 quotation mark (") 

 pipe symbol (|) 

 colon (:) 

 semicolon (;) 

Printing Report 

Report printing is discussed in a later section of this document. 
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Project Properties 

The ‘Project Properties’ (Figure 3) are accessed from the File menu. This screen is used to identify 
general analysis information (e.g., analyst, analysis date, and freeway name). All of these inputs are for 
informational purposes only and do not affect the analysis results. 
 

 
Figure 3 

The Project Properties screen contains the following two sections:  
 
File Information: This area contains information that is only used for file identification purposes. The 
Analyst entry is for the name of the person performing the data entry and analysis. Analysis Date should 
reflect the date of the latest analysis. Upon starting a new file, this field will be automatically populated 
with the current date. The Agency entry refers to the name of the agency where the Freeway Facility 
program is registered. The Notes section is for any additional notes on the analysis that may be of some 
relevance. 
Freeway Facility Information: This area contains entry fields for the following items: 

Freeway Name: The name of the main freeway being studied. 
From: The starting point of the freeway facility under analysis. 
To: The ending point of the freeway facility under analysis. 
Location: Insert the geographic location of the freeway facility that is under analysis (e.g., 
Gainesville, Florida). 
Analysis Direction: The direction of freeway being studied (e.g., Northbound). 
Analysis Period: The time frame for which the traffic demand on the freeway is being studied. The 
user can type in an analysis period or select one of the following options presented in the drop-
down list: AM Peak, PM Peak, Mid-day Peak. 
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View Menu and Lower Toolbar 

 
The ‘View’ menu and the toolbar at the bottom of the screen are used to select the individual 
input/output screens.  The options are: 

 Inputs 

 Time Period Results 

 Overall Results 

 Performance Measure Results 

 Report 
 
Each of these screens are discussed in detail in the Input/Output Screens section. 
 

Help Menu 

 
From the ‘Help’ menu, the user guide and ‘About’ screen can be accessed.  The user guide can also be 

loaded by clicking on the  button in the upper toolbar. 
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Input/Output Screens 

Inputs Screen 

 

Adding and Deleting Time Periods 

Time periods can be added or deleted from a project by using the buttons shown in Figure 4. 
 

 
Figure 4 

Add a Time Period 

When a new project is started, the file begins with only one time period. The user can add an unlimited 
number of time periods by clicking on the 'Add Time Period' button. Notice that new time periods will 
show the same inputs as those of the previous time period until the user manually changes them to 
the desired values. 

Delete a Time Period 

A time period (if the project currently contains more than one time period) can be deleted by clicking 
on 'Delete Time Period' button. 

Time Period Selection 

The time period selection input (upper-left portion of the screen) can be used to select the time period 
for which to display corresponding segment values. 
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Adding, Inserting, and Deleting Segments 

These three functions are accomplished through the Inputs screen, and only during the first time 
period.  The location of these functions is displayed in Figure 5. 
 

 
Figure 5 

Add New Segment 

1) Select any cell on the Inputs screen (except the drop-down cells). 
2) Click the "Add New Segment" button. 
 
Added segments will be added after all existing segments.  Added segments will be basic segments and 
the row will contain all of the default values for the basic segment type. 

Delete a Segment 

1) Select any segment which you wish to delete by clicking on the cell that indicates the number of the 
row that segment lies in. (The entire row will be highlighted.) 

2) Click the "Delete Segment" button. 

Insert a Segment 

1) Select the row above which you want a new segment by clicking on the cell that indicates the number 
of the selected row. (The entire row will be highlighted.) 

2) Click the "Insert New Segment" button. 
Inserted segments will be basic segments and the row will contain all of the default values for the basic 
segment type. 
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Show Segments 

There are five options to choose from in the Show Segments feature: All, Basic, On-ramp, Off-ramp, 
and Weaving. This option allows users to conveniently view only the inputs of specific Segment Types. 

Facility Length 

The freeway facility length is the sum of the individual segment lengths minus any ramp overlap 
segments.  This value cannot be directly edited. 

Jam Density 

The maximum density that can be achieved on a segment. It occurs when speed is zero, i.e., when there 
is no movement of persons or vehicles.  This value applies to the entire facility and cannot be varied by 
segment or time period. 

Bottleneck Capacity Reduction Proportion 

This is the proportion by which the capacity value will be reduced at bottleneck locations (i.e., a queue 
discharge situation).  For example, a value 0.10 will reduce the capacity flow rate by 10%. 

Segment Inputs 

The following variables can be directly edited on this screen: 
 
From:  A text label corresponding to the general start location of the segment. 
To:  A text label corresponding to the general end location of the segment. 
Segment Type:  One of the following segment types can be specified—basic, on-ramp, off-ramp, ramp 

overlap, or weaving.  For guidance on which segment type is appropriate for your analysis, please 
consult the Highway Capacity Manual. 

Length:  This value should be entered in units of feet. 
Terrain: General terrain categories or a specific grade can be specified. 
 
The other variable values shown on this screen must be specified/edited in the specific segment input 
screens.  Accessing these variable inputs is done by clicking on the ‘Edit’ button under the ‘Edit 
Segment’ column.  If the button is yellow, it can be selected because the first time period is currently 
selected.  For any other time periods, the buttons will not be yellow and will not be enabled. 
 
The remainder of this section will discuss the segment-specific inputs. 
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Basic Segment 

 
Figure 6 

 
Please refer to the Highway Capacity Manual for the definitions of these variables.  Other than free-
flow speed, all values are entered directly on this screen.  To specify the free-flow speed, click on the 
‘Set’ button under the ‘Set FFS’ column.  This will bring up the following screen (Figure 7). 
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Figure 7 

The free-flow speed resulting from the inputs on this screen will be entered into the ‘Free Flow Speed’ 
column on the previous screen (Figure 6). 

On- or Off-Ramp Segment 

Mainline roadway and ramp roadway inputs must be specified for an on-ramp (Figure 8) or off-ramp 
(Figure 9) segment. 
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Figure 8 

 

 
Figure 9 

 
On-Ramp Acceleration Lane Length (ft):  For two-lane ramps, the effective acceleration length must 
be calculated by the user based on the lengths of the two lanes.  The formula for calculating effective 
acceleration length is: 



 

HCM-CALC—Freeway Facility Module User Guide 12 

 

Effective Acceleration Length = 2 × LA1 + LA2 

 
where: 
LA1 = Length of the shorter acceleration lane 
LA2 = Difference in length between the longer acceleration lane and the shorter acceleration lane. 
 
Off-Ramp Deceleration Lane Length (ft):  For two-lane ramps, the effective deceleration length must 
be calculated by the user based on the lengths of the two lanes.  The formula for calculating effective 
deceleration length is: 
 
Effective Deceleration Length = 2 × LD1 + LD2 

 
where: 
LD1 = Length of the shorter deceleration lane 
LD2 = Difference in length between the longer deceleration lane and the shorter deceleration lane. 
 

Ramp Overlap Segment 

 
Figure 10 
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Weaving Segment 

 
Figure 11 

There are two types of weave configurations. 
 
One-Sided Weave: A one-sided weave is configured with an on-ramp followed closely by an off-ramp 
on the same side of the freeway's analysis direction. At least one auxiliary lane connects the two ramps 
as shown in Figure 12. 
 

 
Figure 12 

 
Two-Sided Weave:  A two-sided weave is configured with an on-ramp on one side of the freeway's 
analysis direction, closely followed by an off-ramp on the opposite side as shown in Figure 13. 
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Figure 13 

 
Note that the on-ramp and off-ramp demand volumes should not include the ramp-to-ramp volume. 
 
A weaving segment also requires a short length input, which may be shorter than the segment length. 
 

Time Period Results Screen 

Once all the inputs have been specified, select the ‘Time Period Results’ screen from the ‘View’ menu 
or lower toolbar.  The time period results reports the performance measures for each segment of each 
time period.  The time period can be selected by using the scroll button at the top left corner of the 
screen. Each time period also includes the performance measure values over the entire facility in the 
last row of the display. 
 

 
Figure 14 
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The following outputs are included (The definitions of most of these terms are quoted from the Highway 
Capacity Manual): 
 
Adjusted Demand:  The adjusted demand is a function of the Input Demand and Demand Adjustment 

Factors (i.e., Demand × Demand Adj. Factor). 
Volume Served:  The maximum hourly directional volume that can be sustained in a given segment 

without violating criteria for LOS during the worst 15 min of the hour under prevailing roadway, 
traffic, and control conditions. 

Adjusted Capacity:  Capacity is the maximum sustainable hourly flow rate at which vehicles reasonably 
can be expected to traverse a point on a segment during a specified period under prevailing 
roadway, traffic, and control conditions.  Adjusted Capacity is the input capacity times the capacity 
adjustment factor. 

d/c Ratio:  The ratio of demand volume to capacity for a system element. 
v/c Ratio:  The ratio of flow rate to capacity for a system element. 
Queue Length:  The maximum queue length is the furthest upstream point (measured from the 

downstream end of a segment) that vehicle queuing reaches on a segment during the given time 
period. 

Queue Start Time Step:  When the demand/capacity ratio exceeds 1.0 at any location, a queue will 
form and propagate upstream. The queue start time step is the time at which this queue begins to 
form. Likewise, the ‘queue end time step’ is the time at which this queue clears. 

Queue End Time Period:  When the demand/capacity ratio exceeds 1.0 at any location, a queue will 
form and propagate upstream. The ‘queue end time step’ is the time at which this queue clears. 

Average Speed:  The average speed for a segment is determined from the flow rate on the segment 
and the free flow speed of the segment. That is, the speed-flow relationship defined in the HCM is 
used to determine segment speed. 

Density:  Density is defined as the number of vehicles occupying a given length of highway, expressed 
as passenger cars per mile per lane (pc/mi/ln) or vehicles per mile per lane (veh/mi/lane). It is the 
performance measure that determines Level of Service.  Density is computed as rate of flow 
(pc/h/ln) divided by speed (mi/h). 

Average Travel Time:  The average time spent by vehicles traversing a freeway segment, including 
delay. 

Free-Flow Travel Time:  The time spent by vehicles traversing a freeway segment which is unaffected 
by upstream or downstream conditions. 

Mainline Delay:  The mainline delay is the additional travel time experienced by vehicles traversing the 
primary through roadway (distinct from ramps and auxiliary lanes). Additional travel time goes 
beyond that required to travel at the desired speed. 

System Delay:  The additional travel time experienced by drivers across all of the freeway facility. 
VMT Demand:  The VMT (Vehicle Miles of Travel) Demand is based on the demand volume. 
VMT Volume:  The VMT (Vehicle Miles of Travel) Volume is based on the actual volume served. 
VHT:  The VHT (Vehicle Hours of Travel) represents the average total time spent by vehicles traversing 

a highway segment.  Refer to the HCM Chapter 10 for more details on how this value is calculated. 
VHD:  The VHD (Vehicle Hours of Delay) represents the additional number of hours spent traveling by 

the driver due to his/her inability to travel at the desired speed.  Refer to the HCM Chapter 10 for 
more details on how this value is calculated. 
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Segment LOS:  Segment and Facility Level of Service is based on density, as shown in the following 
table. 

 

Level of Service A B C D E F 

Basic Segment Density 
Thresholds 

11 18 26 35 45 > 45 

On-/Off-Ramp 
Segment Density 

Thresholds 
10 20 28 35 >35 d/c > 1 

Weaving Segment 
Density Thresholds 

10 20 28 35 >35 d/c > 1 

Facility Density 
Thresholds 

11 18 26 35 45 > 45 

 
The last column in this screen contains a button (Figure 15) that allows you to load individual segment 
results into the corresponding segment module from HCM-CALC.   
 

 
Figure 15 

 
For example, clicking this button for segment 6 (weaving) will load the inputs for this segment for the 
given time period (Figure 16).  This will allow you to view intermediate calculation results that are not 
available directly in the Freeway Facility module. 
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Figure 16 

Overall Results Screen 

The Overall Results screen contains many of the same outputs provided in the Time Period Results 
screen; however, in this screen the displayed values are averages for each segment, across all time 
periods. The last row contains the facility-wide values across all time periods.  This screen can be loaded 
by selecting ‘Overall Results’ from the ‘View’ menu or lower toolbar. 
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Figure 17 

 

Performance Measure Results Screen 

A view of performance measures displayed in a grid with segments on one axis and time periods on 
another axis can be viewed on the ‘Performance Measure Results’ screen, again, accessed from the 
‘View’ menu or lower toolbar. 
 
Three colors are displayed in the grid: green, yellow, and red.  The threshold values used to determine 
which color to use in a cell can be changed at the top of the screen (Figure 18). 
 
Several performance measures are available for viewing (Figure 19).  When a different performance 
measure is selected, the color threshold values are revised accordingly (Figure 20). 
The values from this grid can be copied to the clipboard by pressing the button labeled as such.  The 
values can then be pasted into a spreadsheet program. 
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Figure 18 

 
Figure 19 
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Figure 20 

 

Report Screen 

To view the inputs and outputs in a formatted report, select the ‘Report’ screen (Figure 21).  In addition 

to selecting this screen through the ‘View’ menu and lower toolbar, you can also click on the  
button. 
 

To print the report, click on the  button or select ‘Print’ from the 'File' menu.  This will bring up the 
standard Print dialog box.  Select the appropriate options, and then press Ok to print the document.  
Note that this print feature relies on the Internet Explorer browser control; thus, to change page 
formatting settings, you need to do this through the ‘Page setup’ option in Internet Explorer (under the 
‘File’ menu). 
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Figure 21 

 

Miscellaneous Features 

 

Copy and Paste Text 

This feature was included in the Freeway Facility module to allow users to conveniently insert results 
into another program, such as a spreadsheet program. To copy and paste values from the Freeway 
Facility module to another program, follow these steps: 
 

1) Highlight the text you would like to copy. 
2) Right-click somewhere within the highlighted area and select 'Copy'. 
3) Open another program and then select 'Paste' or press CTRL+V to insert the clipboard content. 
 

Note that this feature does not work for any checkbox inputs.  
A simple example of this feature is presented below. The copy and paste feature was used to transfer 
the Adjusted Demand and the Volume Served of eight different segments from the Freeway Facility 
module to a spreadsheet program. 
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Copy Paste 

   
 
 

Fill Down 

This feature was included in the Freeway Facility module to expedite the process of entering data for 
multiple segments. When activated, this feature will populate the fields below with the value that was 
"filled down".  The "Fill Down" feature is convenient when entering data for many segments and/or 
time periods that share common values.  To "fill down" a number and/or a checkbox, right-click in the 
cell with the value of interest and click "Fill Down".  
 
Note that this feature cannot be used while a cell value is being edited (i.e., the cell is highlighted in 
yellow). This is because the program must first determine that the value being entered is valid. 
 
A simple example of this feature is presented below. The "Fill Down" feature was used to change the 
segment's demand from 100 to 300 in all of the time periods.  
 
Before After 
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When you have a question 

If you require support for the use of the Freeway Facility module beyond what is contained in this user 
guide, refer to the frequently asked questions list at www.swashware.com or contact Dr. Scott 
Washburn. To report a possible malfunction of the software, please contact Dr. Scott Washburn. 
 
Email: swash@ce.ufl.edu 
Website: swash.essie.ufl.edu 

 


